DSCP LÀ GÌ ? QUALITY OF SERVICE (QOS) CHO HỎI ĐÔI ĐIỀU VỀ QUALITY OF SERVICE (QOS)

 - 

thường thì, khối hệ thống mạng hoạt động bên trên đại lý phân phối hận cực tốt, Tức là toàn bộ gói tin ở mạng đều sở hữu mức độ ưu tiên tương tự và gồm thời cơ được đưa đến đích một biện pháp kịp lúc. lúc ùn tắc xảy ra, toàn bộ những gói tin hầu hết có khả năng bị tắc nghẽn. Nếu không tồn tại QoS, Switch đã hỗ trợ các dịch vụ tốt nhất có thể mang đến tất cả những gói, bất cứ văn bản gói tốt kích cỡ. Nó sẽ gửi những gói tin cơ mà không có ngẫu nhiên sự bảo vệ về độ tin yêu, số lượng giới hạn độ trễ hoặc thông lượng làm sao.Quý Khách đang xem: Dscp là gì

Lúc ta áp dụng khả năng QoS, ta có thể chọn 1 dạng gói tin cụ thể, ưu tiên nó theo khoảng quan trọng kha khá của nó và áp dụng chuyên môn cai quản tắc nghẽn và tránh giảm tắc nghẽn nhằm cung cấp chiết khấu. Việc triển khai QoS vào mạng làm cho hiệu năng mạng dễ dàng dự đân oán rộng cùng áp dụng băng thông kết quả hơn.

Bạn đang xem: Dscp Là Gì ? Quality Of Service (Qos) Cho Hỏi Đôi Điều Về Quality Of Service (Qos)

II. Cơ chế hoạt động

-Việc thực hiện QoS được dựa trên kiến ​​trúc các dịch vụ sáng tỏ (Diff-Serv), kiến trúc này hướng đẫn rằng từng gói tin được phân nhiều loại Lúc nhập lệ mạng. Các gói tin sẽ tiến hành khắc ghi nlỗi Class of Service (CoS), DSCPhường, IPhường Precedence… Nên lưu lại gói tin càng nhanh càng tốt, Lúc được ưu tiên sớm thì luồng đi qua sản phẩm công nghệ tiếp theo vẫn trơn tuột tru.

1, Giá trị IP Precedence và DSCP. (Differentiated Service Code Point)

Layer 3

IPhường Precedence và DSCP.. là nhị trường được sử dụng những độc nhất vô nhị nhằm khắc ghi. Các công cụ QoS thực hiện bọn chúng bởi vì header của gói tin IP trường thọ làm việc rất nhiều khu vực trên mạng.Trong IP header của từng gói tin bao gồm đựng một trường gọi là ToS (Type of Service). Trường Type of Service có giá trị 1 byte. Và 3 bits trước tiên (P2 cho P0) dùng để cách thức những giá trị ghi lại độ ưu tiên của packet cùng các quý hiếm này được hotline là IP Precedence.


*

IP Precedence hoặc DSCP


*

Cấu trúc trường Type of Service

Giá trị IP precedence ở trong khoảng từ bỏ 0 mang lại 7.

Tại sao lại sở hữu những khoảng tầm quý hiếm trên, ví dụ nhỏng sau:

3 bits trước tiên (P2 mang lại P0): IP Precedence. Do sử dụng 3 bits đề xuất sẽ sở hữu 8 cực hiếm (000 mang đến 111) định ra độ ưu tiên của gói tin tự thấp cho cao. Giúp router xử trí các gói tin này theo quality dịch vụ. Ví dụ, gói tin được khắc ghi với mức giá trị IP Precedence là 7 (111) sẽ sở hữu được độ ưu tiên về bandwidth, được thoát khỏi hàng ngóng trước… hơn so với các gói tin được ghi lại với cái giá trị IP Precedence là 3 (011).

3 bits tiếp theo (T2 mang đến T0):

bit T2 (T2=1): Yêu cầu truyền cấp. bit T1 (T1=1): Yêu cầu truyền với mặt đường truyền rất tốt. bit T0 (T0=1): Yêu cầu truyền bảo vệ.

2 bit cuối (CU1-CU2): Không sử dụng cho tới (Currently & Unused).

Tuy nhiên, hiện giờ không cần sử dụng các quý hiếm của IPhường. Precedence để đánh dấu gói tin. Với mục tiêu làm tăng tác dụng unique hình thức dịch vụ thì các vẻ ngoài QoS vẫn dùng những quý giá được Hotline là vấn đề mã hình thức tách biệt DSCPhường (Differentiated Service Code Point) nhằm triển khai ghi lại gói tin. 3 bits IP Precedence vẫn kết phù hợp với 3 bits tiếp theo sau (từ T2 cho T0) tạo ra thành 6 bits biểu đạt các cực hiếm của DSCPhường. Do đó các giá trị DSCP nằm trong khoảng từ bỏ 0 đến 63.

Các bits này được ánh xạ nlỗi sau:


*

Giá trị IP Precedence hoàn toàn có thể được ánh xạ mang lại trường DSCP

6 bits DiffServ (DS) từ bỏ DS5 đến DS0 được dùng làm đánh dấu gói tin và đã cho thấy cách thức từng router cách xử lý gói tin như thế nào. Với 6 bits có thể tạo nên mang lại 64 class hình thức dịch vụ.


*

IPhường Header trước với sau đánh dấu DSCP

Lựa lựa chọn giá trị DSCP buộc phải tương thích với sản phẩm trường đoản cú IP Precedence. Nói cách khác là phải so trùng khớp quý giá của 3 bits thứ nhất. Mọi sự biến đổi phần đa nên để ý đến sự trùng khớp này.Ví dụ: quý hiếm IPhường. Precedence là 5 (101) thì quý giá DSCPhường có thể là 101 000.


*

Có các hình trạng nối tiếp gói tin trong DSCP là AF (assured forwarding: bảo đảm an toàn đẩy gói) với EF (expedited forwarding: xúc tiến đẩy gói), chọn lớp (Class Selector) với mang định (Default).


Ánh xạ thân PHB cùng DSCP

Với EF: độ trễ, độ dịch chuyển trễ, tỉ trọng mất gói phải chăng, đường dẫn được bảo đảm an toàn, với hình thức dịch vụ cuối cùng buộc phải trải qua miền DiffServ. EF được thực hiện mang lại các luồng bao gồm độ ưu tiên không nhỏ.

Với AF: định rõ đều hình thức khác nhau sẽ tiến hành đảm bảo an toàn chuyển tiếp, thông qua miền DiffServ. AF được chia thành 4 lớp (class) đảm bảo đẩy gói khác nhau với 3 mức độ ưu tiên loại trừ gói (drop precedence) khẳng định khác biệt. AFxy, x (chỉ số lớp) càng tốt thì xếp vào hàng ngóng xuất sắc hơn, x càng nhỏ tuổi thì sẽ càng dễ dàng bị loại bỏ vứt, y càng tốt thì gói tin càng dễ bị loại quăng quật. Vậy AF41 là gói tin được ưu tiên tốt nhất, mang lại AF42, AF43,… AF13 dễ dàng bị loại bỏ nhất


2, Gía trị cos (class of service) Layer 2

Cos: Class of service: Các lớp các dịch vụ (0 cho 7)

Trường CoS chỉ trường thọ phía bên trong Etheframe lúc những mặt đường trunk 802.1Q với ISL được sử dụng. cũng có thể áp dụng ngôi trường này nhằm thiết lập cấu hình 8 giá trị nhị phân không giống nhau nhưng có thể dùng mang đến chức năng phân loại của qui định QoS nlỗi IPhường. Precedence với DSCP.. Giá trị Cos càng tốt thì gói tin frame càng được ưu tiên.


Cos 7: Không thực hiện (reserved)

Cos 6: Không áp dụng (reserved)

Cos 5: Dữ liệu voice (voice bearer)

Cos 4: Dữ liệu đoạn Clip conferencing

Cos 3: gọi signalling

Cos 2: High priority data

Cos 1: Medium priority data

Cos 0: best effort data


Hình 2: lấy ví dụ ví dụ về gán quý hiếm CoS với DSCP

Theo hình 2, minch hoạ một LAN switch thực hiện chức năng QoS dựa trên CoS. R3 hiểu các frame bước vào trên một cổng (ví dụ F0/9), lưu lại cực hiếm DSCPhường dựa trên các thông số CoS. Thêm vào kia R3 phát âm những quý giá DSCP cho các gói tin vẫn ra đi cổng F0/0 về SW2, gán cực hiếm trong 802.1Q header. Giá trị thực sự trên cổng F0/0 của R3 cho quá trình phân các loại và lưu lại như sau: Các frame bước vào với mức giá trị CoS 5 sẽ tiến hành gán quý giá DSCPhường EF (mức ưu tiên mập nhất) Các frame lấn sân vào với giá trị CoS 1 sẽ được gán giá trị AF11.

3, Mô hình Qos


Phân một số loại (classification): Phân loại một gói tin bằng phương pháp liên kết nó với nhãn QoS. Bộ thay đổi ánh xạ CoS hoặc DSCPhường vào gói tới nhãn QoS để minh bạch một một số loại lưu lại lượng truy cập với một nhiều loại không giống. Kiểm tra gói và khẳng định nhãn qos dựa trên ACL hoặc cấu hình.

Chính sách cùng ghi lại (policing & marking):

Sau Lúc gói được phân nhiều loại với có nhãn QoS dựa trên DSCP hoặc dựa vào CoS được gán mang lại nó.

Policing liên quan đến sự việc tạo nên một policer xác minh số lượng giới hạn băng thông đến lưu lượt truy vấn. Các gói quá quá giới hạn nằm ko kể cấu hình hoặc ko tương xứng. Mỗi policer đưa ra quyết định bên trên đại lý packet-by-packet mặc dù gói tin cân xứng hay là không phù hợp và chỉ định và hướng dẫn các hành động trên gói. Những hành động này, được triển khai bởi vì marker, bao hàm trải qua gói tin nhưng mà không sửa thay đổi, quăng quật gói tin, hoặc sửa thay đổi (khắc ghi xuống) DSCP được hướng dẫn và chỉ định của gói và chất nhận được gói trải qua.

Hàng ngóng (queue):

Hàng chờ nhận xét nhãn QoS với cực hiếm DSCPhường hoặc CoS tương xứng nhằm lựa chọn thành nhì mặt hàng ngóng nhập vào để đặt gói tin. Xếp hàng được bức tốc với thuật tân oán weighted tail drop (WTD), một hình thức tránh tắc nghẽn. Nếu quá quá ngưỡng, gói tin đã bị nockout vứt.

Lập chiến lược hình thức dịch vụ những sản phẩm ngóng dựa trên shaped round robin (SRR) được định thông số kỹ thuật của bọn chúng. Một trong những mặt hàng chờ đột nhập là sản phẩm ngóng ưu tiên, cùng SRR hình thức nó đến chia sẻ được thông số kỹ thuật của chính nó trước khi Giao hàng sản phẩm ngóng khác

4. Cấu hình Standard Qos trên Switch layer 3

Khởi tạo ra Qos trên switch 3750 catalyst (mang định disable)

Sw(config) mls qos no mls qos

Show mls qos

Khởi tạo thành qos dựa vào vlan

Int g0/0

Sw(config) mls qos vlan-based no mls qos vlan-based

Show mls qos int g0/0

Cấu hình qos bên trên những cổng tin cẩn (mặc địch thiếu tín nhiệm cậy)

Sw(config) int g0/0

Mls qos trust no mls qos trust int g0/0

Cấu hình quý giá cos, dscp, ip pre đến gói tin cấu hình class-map:

Câu lệnh class-map: dùng để phân một số loại giữ lượng tài liệu theo nguyện vọng của người sử dụng, rất có thể thực hiện kết hợp với những quy định phân loại nhỏng ACL giỏi cần sử dụng cơ chế NBAR.Câu lệnh policy-map: dùng làm hiện tượng giải pháp hành xử cho từng loại lưu giữ lượng đã có được phân loại, cách hành xử có thể dễ dàng và đơn giản là phân loại tài liệu, rất có thể là đánh dấu thường được sử dụng trong những nguyên lý QoS khác, để ý là luôn luôn tồn tại một một số loại thông số kỹ thuật class-map tên là class-default nhằm mục đích phân nhiều loại toàn bộ những lưu lại lượng chưa được phân một số loại do phần lớn class-map trước.

SW (config) # class-mapname

SW (config-cmap) # match access-group Name access-list-name

SW (config-cmap) # match coscos-value

SW (config-cmap) # match dscpdscp-value-1

SW (config-cmap) # match ip precedenceip-precedence-value-1

Hoặc

SW (config)#policy-mapname

SW (config-pmap)#classname

SW (config-pmap-c)#mix ip precedenceip-precedence-value-1

SW (config-pmap-c)#set dscpdscp-value-1

SW (config-pmap-c)#phối cos cos-value

Ta có:

SW (config-cmap) # class-maps (match-any | match-all)name

SW (config-cmap) # match access-group name test

SW (config-cmap) # match int f0/1


Ví dụ: Cấu hình trên SWC làm thế nào cho PC0, PCmột lạng traffic mail được ưu tiên hơn cùng với website, cùng traffic còn sót lại của VPS local

Cách 1: Tạo 2 access danh sách mail (pop3) vs web (http https)

SWC(config)#ip access-list extendedmail

SWC(config-ext-nacl)#permit tcp any host 2.2.2.2 eq 110

SWC(config-ext-nacl)#ex

SWC(config)#ip access-list extendedweb

SWC(config-ext-nacl)#permit tcp any host 2.2.2.2 eq 80

SWC(config-ext-nacl)#permit tcp any host 2.2.2.2 eq 443

Bước 2: Tạo 2 class map tương ứng với access-list

SWC(config)#class-mapmail

SWC(config-cmap)#match access-group namemail

SWC(config-cmap)#ex

SWC(config)#class-mapweb

SWCconfig-cmap)#match access-group nameweb

SWC(config-cmap)#ex

Bước 3: Tạo policy map cùng gán quý hiếm ip precedence, class-mặc định là lượng traffic sót lại.

SWC(config)#policy-mapabc

SWC(config-pmap)#classmail

SWC(config-pmap-c)#phối ip precedence 3

SWC(config-pmap-c)#ex

SWC(config-pmap)#classweb

SWC(config-pmap-c)#mix ip precedence 2

SWC(config-pmap-c)#ex

SWC(config-pmap)#class class-default

SWC(config-pmap-c)#phối ip precedence 1

SWC(config-pmap-c)#end

Cách 4: Gán policy-maps vào cổng

SWC(config)#int range f0/1-2

SWC(config)# service-policy inputabc

Vậy ở chỗ này chúng ta vẫn ưu tiên những gói tin theo mail với mức giá trị ip predence cao hơn bắt buộc đi trước, vì vậy đang truy vấn nkhô giòn rộng đối với website cùng luồng tin còn lại.

Gán giá trị cos-to-dscp: Quý Khách áp dụng CoS-to-DSCPhường. để ánh xạ những giá trị CoS trong số gói dữ liệu mang lại một giá trị DSCPhường. cơ mà QoS áp dụng trong nội cỗ nhằm bộc lộ cường độ ưu tiên của giữ lượt truy vấn.

Xem thêm:

SW1(config)#mls qos bản đồ ?

cos-dscp cos-dscp map: eight dscp values for cos 0-7

SW1(config)#mls qos maps cos-dscp 0 8 16 24 32 46 48 56

SW1(config)#exit

SW1#show mls qos maps cos-dscp

Cos-dscp map: cos: 0 1 2 3 4 5 6 7

dscp: 0 8 16 24 32 46 48 56

Vậy toàn bộ giá trị cos từ 0 mang đến 7 được gán cực hiếm DSCP. theo thứ tự: 0, 8, 16, 24, 32, 46, 48, 56

Ánh xạ giá trị dcsp-to-dscp mutation map: Nếu nhị miền QoS có DSCP.. không giống nhau, hãy sử dụng DSCP-to-DSCPhường mutation bản đồ nhằm dịch một bộ cực hiếm DSCP để tương xứng với có mang của miền khác.

Giá trị DSCPhường mới đang ghi đè lên trên một gói vào gói cùng QoS giải pháp xử lý gói với cái giá trị bắt đầu này. Công tắc đang gửi gói tin ra khỏi cổng với giá trị DSCPhường new.

quý khách hoàn toàn có thể cấu hình những DSCP-to-DSCPhường mutation maps trên cổng vào.


SW1(config)#mls qos maps dscp-mutationDEMO24 26 28 30 to 24

SW1(config)#interface gig 1/0/8

SW1(config-if)#mls qos trust dscp

SW1(config-if)#mls qos dscp-mutation

DEMO SW1(config-if)#bởi vì show mls qos maps dscp-mutation

Dscp-dscp mutation map:


Các quý hiếm dscp 24 26 28 30 đang ánh xạ thành 24

5. Cấu hình qos bằng policy map và class map

Cấu hình với một luồng con đường đi

Cách 1: Tạo class-bản đồ kết phù hợp với access-các mục, chúng ta cũng có thể sử dụng access-danh mục theo từng host PC, hoặc theo từng dịch vụ nhỏng web, mail.

Switch(config)# access-danh sách 1 permit 10.1.0.0 0.0.0.255

Bước 2: Tạo policy-map kết hợp với class-map sống trên, kế tiếp cấu hình để tăng giảm băng thông, 1000000: Băng thông số lượng giới hạn bps, 8000: Tốc độ burst Bytes

Switch(config)# class-mapipclass1

Switch(config-cmap)# match access-group 1

Switch(config-cmap)# exit

Switch(config)# policy-mapflow1t

Switch(config-pmap)# classipclass1

Switch(config-pmap-c)# trust dscp

Switch(config-pmap-c)# police 1000000 8000 exceed-action policed-dscp-transmit

Switch(config-pmap-c)# exit

Switch(config-pmap)# exit

+ Bước 3: Cấu hình gán dịch vụ policy vào cổng thiết bị lí, input hoặc output

Switch(config)# interface gigabitetheg0/0

Switch(config-if)# service-policy inputflow1t

Tại đây bọn họ gồm hình cấu hình qos trên SW 3560 nhằm tăng giảm đường truyền mang lại vùng mạng Lan, mặc dù tùy ở trong vào lượng băng thông nhưng ISP cấp cho đến. Trong khi rất có thể cấu hình qos trên Router ISP..

Cấu hình với nhiều luồng mặt đường đi:


Sử dụng chính sách aggregate

Cách 1: Tạo aggregate-police với 320000 là đường dẫn, 8000 là tốc độ burst.

SW1(config)#mls qos aggregate-policeWeb-telnet320000 8000 exceed-action drop

Bước 2: Tạo 2 access-danh sách, tạo ra 2 class-maps gán cùng với 2 access-danh mục đó

SW1(config)#access-các mục 100 permit tcp 192.168.1.0 0.0.0.255 192.168.đôi mươi.6 0.0.0.0 eq 80

SW1(config)#access-danh mục 2 permit 192.168.2.0 0.0.0.255

SW1(config)#class-mapweb

SW1(config-cmap)#match access-group name 100

SW1(config-cmap)#exit

SW1(config)#class-maptelnet

SW1(config-cmap)#match access-group name 2

SW1(config-cmap)#exit

+ Bước 3: Tạo policy-maps AGGREGATE

SW1(config)#policy-map AGGREGATE

SW1(config-pmap)#class web

SW1(config-pmap-c)#police aggregateWeb-telnet

SW1(config-pmap-c)#exit

SW1(config-pmap)#class telnet

SW1(config-pmap-c)#police aggregateWeb-telnet

SW1(config-pmap-c)#exit

SW1(config-pmap)#exit

Bước 4: Gán service policy vào cổng vật lí

SW1(config)#interface f0/1-2

SW1(config-if)#service-policy input AGGREGATE

Vậy thì PC0 đã truy cập website với PC1 temang lại server local, cùng với lượng băng thông tầm thường đang thông số kỹ thuật là 3,2Mbps

Policing a Switched Virtual Interface:

Cách 1: Cấu hình tin tưởng vlan-based bên trên cổng trang bị lí.

SW1(config-if-range)#mls qos vlan-based

SW1(config-if-range)#exit

Cách 2: Tạo access-danh mục, chế tạo ra 1 class-map khớp ứng, sinh sản 1 class-maps gán với cổng thiết bị lí.

SW1(config)#access-danh mục 100 permit udp any any range 16384 32767

SW1(config)#class-map RTP

SW1(config-cmap)#match access-group 100

SW1(config-cmap)#exit

SW1(config)#class-map PORTS

SW1(config-cmap)#exit

Cách 3: Tạo 1 policy-bản đồ để số lượng giới hạn đường truyền (child policy map), sinh sản 1 policy map (parent policy map) nhằm gán quý giá dscp, gán them child policy-bản đồ nghỉ ngơi trên

SW1(config)#policy-map PORT

SW1(config-pmap)#class PORTS

SW1(config-pmap-c)#police 256000 8000 exceed-action drop

SW1(config-pmap-c)#exit

SW1(config-pmap)#exit

SW1(config)#policy-map VLAN

SW1(config-pmap)#class RTP

SW1(config-pmap-c)#mix dscp 46

SW1(config-pmap-c)#service-policy PORT

SW1(config-pmap-c)#exit

SW1(config-pmap)#exit

SW1(config)#int vlan 100

SW1(config-if)#service-policy input VLAN

Dưới dây là 1 ví dụ khác: Đây là phần lớn vlan đang bao gồm và yêu cầu là cung cấp băng thông, đặt cực hiếm ip precedence mang đến từng mô hình dịch vụ. Ta vẫn cấu hình trên sw 3560

VLAN ID VLAN NAME BANDWIDTH PRECEDENCE

--------------------------------------------------------------------------------

10 IPMux 16 Mbps 5

trăng tròn Cameras 2 Mbps 7

30 Scada 6 Mbps 6


Bước 1: Khởi tạo ra qos

mls qos

Cách 2: Tạo policy map:

Ví dụ: policy-map bw6M (child policy map) để số lượng giới hạn đường truyền, policy-map vlan 30 (parent policy-map) để tại vị giá trị ip precedence

!

policy-bản đồ bw6M

description *************** VLAN 30 Scadomain authority ***************

class class-default

police 6000000 8000 exceed-action drop

policy-maps VLAN30

class class-default

phối precedence 6

service-policy bw6M

!

policy-map bw2M

mô tả tìm kiếm *************** VLAN trăng tròn Cameras ***************

class class-default

police 2000000 8000 exceed-action drop

policy-maps VLAN20

class class-default

phối precedence 7

service-policy bw2M

!

policy-bản đồ bw16M

description *************** VLAN 10 IPMux ***************

class class-default

police 16000000 8000 exceed-action drop

policy-bản đồ VLAN10

class class-default

set precedence 5

service-policy bw16M

Cách 3: Cấu hình bên trên cổng: access vlan cùng qos cho vlan

interface FastEthernet0/1

switchport mode access

mls qos vlan-based

!

interface FastEthernet0/1

switchport access vlan 10

switchport mode access

mls qos vlan-based

!

!

interface FastEthernet0/2

switchport access vlan 20

switchport mode access

mls qos vlan-based

!

!

interface FastEthernet0/3

switchport access vlan 30

switchport mode access

mls qos vlan-based

!

!

Cách 4: Cấu hình trunking

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

mls qos vlan-based

Bước 5: Assign the policy maps to the SVIs: Gán policy-maps vào vlan

!

interface Vlan10

no ip address

service-policy input VLAN10

!

interface Vlan20

no ip address

service-policy input đầu vào VLAN20

!

interface Vlan30

no ip address

service-policy đầu vào VLAN30

!

Congestion Management:Quản lí tắc nghẽn

Quý Khách hoàn toàn có thể ưu tiên lưu lượng bằng phương pháp đặt những gói có DSCPhường. hoặc CoS vào các mặt hàng ngóng khăng khăng cùng kiểm soát và điều chỉnh ngưỡng mặt hàng đợi nhằm những gói bao gồm cường độ ưu tiên rẻ rộng bị loại bỏ bỏ

Ánh xạ quý giá cos hoặc dscp tới mặt hàng hóng (queue) với ngưỡng (threshold)

Theo mặc định, những giá trị DSCP 0–39, 48–63 được ánh xạ tới queue 1 và threshold 1. Các quý hiếm DSCP.. 40–47 được ánh xạ tới queue 2 và threshold 1.

Theo khoác định, quý giá CoS 0–4, 6 và 7 được ánh xạ tới queue 1 cùng threshold 1. Giá trị CoS 5 được ánh xạ tới queue 2 cùng threshold 1.

Queue: từ 1 cho 2.Threshold: 1 đến 3..

Gán hai Tỷ Lệ ngưỡng WTD cho (threshold 1 với 2) vào sản phẩm hóng nhập. Mặc định, cả nhị ngưỡng được đặt thành 100%.

Đối với ngưỡng tỷ lệ Phần Trăm ngưỡng1, phạm vi từ là một mang lại 100. Tách từng quý hiếm bởi khoảng trắng.

Mỗi quý hiếm ngưỡng là tỷ lệ của tổng số cỗ biểu thị mặt hàng chờ được phân bổ mang đến sản phẩm đợi.

VD:

Switch(config)# mls qos srr-queue input dscp-map queue 1 threshold 1 0 1 2 3 4 5 6

Switch(config)# mls qos srr-queue input đầu vào dscp-bản đồ queue 1 threshold 2 20 21 22 23 24 25 26

Switch(config)# mls qos srr-queue input threshold 1 50 70

lấy một ví dụ này cho biết thêm cách ánh xạ cực hiếm DSCP 0 mang đến 6 để nhập khẩu chờ 1 (queue) cùng mang đến ngưỡng 1 (threshold) với ngưỡng sút 1/2. Nó ánh xạ các giá trị DSCP trường đoản cú đôi mươi cho 26 nhằm nhập cảng hóng 1 và mang đến ngưỡng 2 cùng với ngưỡng bớt 70%. Trong ví dụ này, các quý hiếm DSCPhường (0 mang đến 6) được gán ngưỡng WTD là một nửa với vẫn bị loại bỏ quăng quật sớm rộng giá trị DSCPhường (đôi mươi mang đến 26) được gán đến ngưỡng WTD là 70%.

Dường như có thể ánh xạ giá trị cos

Switch(config)# mls qos srr-queue đầu vào cos-maps queuequeue-idthresholdthreshold-id cos1...cos8

Shaped Round Robin (SRR):

SRR có 2 cơ chế hoạt động

Shaped

Chỉ gồm sẵn bên trên hàng ngóng đi ra.

Hàng đợi nhận ra 1 phần dự trữ 1 phần của một cổng đường dẫn cùng không hề nữa.

Shared

Có sẵn trên hàng hóng vào với ra.

Hàng hóng được bảo đảm một trong những phần của cổng đường truyền.

Bandwidth Allocation for Input Queues (shared mod):Gắn băng thông vào hàng hóng nguồn vào (queue)

SW1(config)#mls qos srr-queue input đầu vào bandwidth 30 70

30% đường truyền mang lại queue 1 và 70% mang lại queue 2

Bandwidth Allocation for Output Queues (shared mod):Gán băng thông đến sản phẩm hóng áp ra output.

Xem thêm: GiảI Mã “NgườI Trinh Nữ Tên Thi” Trong BảN Hit CủA NhạC Sĩ Hoàng Thi Thơ

SW1(config)#int gig 1/0/4

SW1(config-if)#speed 1000

SW1(config-if)#srr-queue bandwidth nói qua 10 25 35 50

BW for Q1: * 1000 Mbps = 83.3 Mbps

BW for Q2: * 1000 Mbps = 208.3 Mbps

BW for Q3: * 1000 Mbps = 291.7 Mbps

BW for Q4: * 1000 Mbps = 416.7 Mbps

Bandwidth Allocation for đầu ra Queues (Shaped Mode): Băng thông giới hạn

SW1(config)#int gig 1/0/5

SW1(config-if)#speed 1000

SW1(config-if)#srr-queue bandwidth shape 30 0 0 0

Determine the amount of bandwidth limits applied to lớn the output queues on interface Gigabit Ethe1/0/5.

BW Limit for Q1: 1/30 * 1000 Mbps = 33.3 Mbps

BW Limit for Q2: No limit applied

BW Limit for Q3: No limit applied

BW Limit for Q4: No limit applied

Example:

SW1(config)#int gig 1/0/6

SW1(config-if)#speed 1000

SW1(config-if)#srr-queue bandwidth mô tả 100 100 40 20

SW1(config-if)#srr-queue bandwidth shape 50 50 0 0

BW Limit for Q1 (Mbps): (1/50) * 1000 = đôi mươi Mbps

BW Limit for Q.2 (Mbps): (1/50) * 1000 = đôi mươi Mbps

Total Bandwidth (Mbps) = đôi mươi + 20 + 640 + 320 = 1000 Mbps

Limiting Bandwidth on an Output đầu ra Interface:

SW1(config-if)#srr-queue bandwidth limit 85

The interface’s outbound bandwidth is limited to 85 percent of the interface speed